UK Imaging Informatics Group
Worklist issues with Philips and GE PreviousNext
UK Imaging Informatics Group > Questions & Answers > PACS Integration & Standards >
Message/Author
 Link to this message Martin Elms  posted on Wednesday, December 17, 2008 - 11:19 am Edit Post Delete Post Print Post
We are currently experiencing problems with a new Philips DR room that has been installed. Currently we can not see a worklist. Bummer.

Instead of pulling the worklist straight from our RIS we pull it from the GE Broker. We have double checked I.P's ports etc and everything seems correct. There is connectivity as we can ping PACS and the Broker.

I was wondering if anyone had the same kit and stumbled across the same problems that we are having at the moment.

Thanks in advance
 Link to this message Simon Waddington  posted on Wednesday, December 17, 2008 - 11:26 am Edit Post Delete Post Print Post
Sounds like a simple BROKER config issue.

You can ping because you have correctly addressed the Philips DR IP wise and I assume Sub Net and Gateway. Just to check config, check port number for the broker you have set on Philips. GE use 3320 as standard on their Mitra box. Also, check AET. GE use 'BROKER' as standard. In CRIS, have you assigned the new room correctly as somewhere you can book exams into? On PACS, has the config been made to recognise it? Finally, check exam type. In PACS the exams will be CR as type on PACS but Philips may only be polling for exam type of DR. This will need to be changed by Philips. Regards. Simon.
 Link to this message Martin Elms  posted on Wednesday, December 17, 2008 - 11:59 am Edit Post Delete Post Print Post
Simon,

Thank you for the quick reply. We have checked port number and as you say it is set to 3320. We do not use CRIS. We use Sunquest RIS. I am guessing the priniciple is the same. The config on the broker can see the room and we can bring it from the broker also which makes me think the philips machine is not set correctly.
 Link to this message Marco Crispini  posted on Wednesday, December 17, 2008 - 12:30 pm Edit Post Delete Post Print Post
So you mean you're getting a worklist response, just the list is empty?

It will likely be the query criteria that are applied by both the broker and modality.

Modality (DR vs CR) is prime candidate, but also they filter sometimes on room code and/or station name, as well as date obviously.

Finally it's a long shot but if the query criteria are open (ie pulling back everything rather than just the worklist intended for that device and day), then the result set could be too large causing an exception and an empty worklist to be returned.

Marco
 Link to this message Martin Elms  posted on Wednesday, December 17, 2008 - 01:36 pm Edit Post Delete Post Print Post
Hi Marco ;o)

No we are not getting a worklist response from the Philips machine. "No response from RIS" but of course we have to assume that this error message is to do with the broker as no direct feed from the RIS.

We can filter out what we can see on that machine. We asked to see all CR/DR examinations for "today" and still nothing.

We have also booked a test patient and searched for that 1 order on accession number and still got the same error message.

Martin
 Link to this message Tony Mottram  posted on Wednesday, December 17, 2008 - 02:04 pm Edit Post Delete Post Print Post
[have you checked on the broker in modality worklist browser? You should be able to pull up the AET of the new kit and view the worklist for it, if it is saturated with a worklist then the kit needs tweaking ]
 Link to this message Ross Clark  posted on Wednesday, December 17, 2008 - 06:03 pm Edit Post Delete Post Print Post
The message ' No response from RIS' is the modality saying it couldn't contact the worklist server. I would check the following - 1. If you can access it, check the dicom log on the broker to see if the association is being made correctly. 2. Use the MWL Browser as suggested to see if the Broker can see the worklist. 3. Use a modality emulator like JDICOM to poll the broker with the modality's AET. 4. If all the above suggest everything is correct I have seen an issue with some GE and Philips modalities which refuse to receive a worklist unless the tags (0008,0102) Code Scheme Designator and (0040,0001) Scheduled Station AE Title are filled. Hope this helps.
 Link to this message D Hagerman  posted on Monday, December 22, 2008 - 04:37 am Edit Post Delete Post Print Post
why not just call your service personell?If this is a new room, then this configuration should be under the installation/warranty.
 Link to this message Tony Mottram  posted on Monday, December 29, 2008 - 09:31 am Edit Post Delete Post Print Post
having exactly the same issues here following a Philips upgrade. Downloaded jdicom to follow step 3 but have never used this app, can anyone help me through this process?
 Link to this message Tony Mottram  posted on Wednesday, December 31, 2008 - 09:16 am Edit Post Delete Post Print Post
We have just upgraded or rather Philips have just upgraded us from VMS to a Windows based platform and have tried everything to get worklists but to no avail. The Philips system suggests it is connected to Cris but fails to retrieve worklists. Philips have suggested that this new platform works at several alternative trust sites and we have now identified that their PACS version albeit the same vendor as ours (AGFA) is version 6 and ours is a much older and some might argue more stable version 5.2. We understand that 5.2 relies on the actual modality having two names specific to itself as separate identifiers for PACS and Cris and that v6 has a connectivity managerment section allowing for one identifier to be recognized by both PACS and Cris and feel this is where the issue lies. Has anyone else had this problem? Is there a solution?
 
Add Your Message Here
Post:
Username: Posting Information:
This is a private posting area. Only registered users may post messages here.
Password:
Options: Automatically activate URLs in message
Action: